bharadwaj-pendyala commented on issue #2602:
URL: 
https://github.com/apache/datafusion-ballista/issues/2602#issuecomment-6495413115

   I'd like to take this one. For the first PR, I'll drop the `web` gate on 
`on_key_sync`, rename `WebKeyAsyncAction` to `KeyAsyncAction`, and have native 
`on_key` call `on_key_sync` before running the returned action through the 
existing `ui::load_*` helpers. That removes the ~330-line native copy and the 
`load_*_popup_data` wrappers that only reselect the job. Native `e`/`j`/`m` 
still go through `ReloadView` and reload whichever view is now current, same as 
today.
   
   I'd leave the per-popup split, the `'1'..='7'` arm and the footer 
`key_hints()` for a second PR so this one stays a straight delete. @martin-g, 
does that split work for you?
   


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to