haochunchang commented on issue #2027:
URL: https://github.com/apache/datafusion/issues/2027#issuecomment-5911572892
The open question on this issue has been what the desired naming behavior
should be, so I wrote up a concrete proposal in #25903.
In short:
- Unaliased columns in the result of a top-level SQL query get readable
labels, such as 1 + 2, sum(a), and row_number() OVER (ORDER BY a).
- The labels are behind an opt-in configuration option that is off by
default.
- Internal names (Expr::schema_name()) don't change, so name resolution,
views, stored schemas, and the DataFrame API keep working.
The biggest open question is whether the label should rename the column or
be attached as field metadata that display tools such as datafusion-cli read.
I'd propose closing this issue and move the discussion to #25903 , any
feedback or other options would be very welcome!
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: [email protected]
For queries about this service, please contact Infrastructure at:
[email protected]
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]