Karsten Blees <karsten.bl...@gmail.com> writes:

> Here's v5 of the performance tracing patch series, now including a bunch of 
> cleanups and adding timestamp, file and line to all trace output.
>
> I'm particularly interested in feedback for the output format. As file names 
> have different lengths, printing file:line as prefix results in unaligned 
> output:
>
>  > GIT_TRACE=1 git stash list
>  00:12:10.544266 git.c:512 trace: exec: 'git-stash' 'list'
>  00:12:10.544266 run-command.c:337 trace: run_command: 'git-stash' 'list'
>  00:12:10.649779 git.c:312 trace: built-in: git 'rev-parse' '--git-dir'
>
> We could add separators to make it easier to parse, e.g.:
>
>  > GIT_TRACE=1 git stash list
>  [00:12:10.544266 git.c:512] trace: exec: 'git-stash' 'list'
>  [00:12:10.544266 run-command.c:337] trace: run_command: 'git-stash' 'list'
>  [00:12:10.649779 git.c:312] trace: built-in: git 'rev-parse' '--git-dir'

This is easier to parse if " " and ":" are found in the names of
_our_ source files and "]" isn't, but is that really the case?

> Or print file:line at the end (but what about multi-line messages, such as 
> packet-trace?):
>
>  > GIT_TRACE=1 git stash list
>  00:12:10.544266 trace: exec: 'git-stash' 'list' (git.c:512)

Somehow I find this a lot harder to read than the other two.

I am not commenting on the usefulness of the patch series (yet),
though.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to