On Sun, Jun 09, 2013 at 11:40:21AM -0500, Felipe Contreras wrote:
> By using good ol' goto.
> 
> Signed-off-by: Felipe Contreras <felipe.contre...@gmail.com>

I don't see this as an indentation change but as a restructing of the
code. I would prefer something more like
"Replace early return with goto cleanup" (but better phrased).

The same goes for the next patch in this serie, I would prefer if the
shortlog tells what have been done, not how hard it was to do. Even
trivial changes can introduce bugs and when the commit message is just
that "this is trivial" it forces me to read the diff to know if that's
something that can effect me or not.

> +leave:
>       free_message(&msg);
>       free(defmsg);

leave: should be cleanup: or out: to conform with already written code. I
suppose there will be a lot of those changes from now on and it will be
easier if the name of the cleanup-label always is the same.

Maybe small things to review, but I think those things will lead to a
better code-base in the long term.

-- 
Med vänliga hälsningar
Fredrik Gustafsson

tel: 0733-608274
e-post: iv...@iveqy.com
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to