Jonathan Nieder wrote:
> Ramkumar Ramachandra wrote:
>
>> --- a/t/t5516-fetch-push.sh
>> +++ b/t/t5516-fetch-push.sh
>> @@ -1,6 +1,6 @@
>>  #!/bin/sh
>>
>> -test_description='fetching and pushing, with or without wildcard'
>> +test_description='fetching and pushing'
>
> I'm not thrilled with the description before or after.  Would it make
> sense to do something like the following?
>
>         test_description='Tests of basic fetch/push functionality.
>
>         These tests create small test repositories and fetch from and
>         push to them, testing:
>
>          * commandline syntax
>          * refspecs and default refspecs
>          * fast-forward detection and overriding fast-forward detection
>          * configuration (insteadOf, pushInsteadOf, [remote "name"] push,
>            etc)
>          * hooks
>          * --porcelain output format
>          * hiderefs
>         '

No.  When I want to add a test for branch.<name>.pushremote, I grep
for branch.*.pushurl, and open files with sensible names; I'm not
going to open up the file and read a long description of what tests it
already contains.  The filename and test headlines are sufficient.
Our test suite is bad enough as it is (inconsistent style, missing &&,
false positives)- I'm against adding to the maintenance burden.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to