On Thu, Sep 20, 2018 at 2:04 PM Taylor Blau <ttayl...@github.com> wrote: > The recently-introduced "core.alternateRefsCommand" allows callers to > specify with high flexibility the tips that they wish to advertise from > alternates. This flexibility comes at the cost of some inconvenience > when the caller only wishes to limit the advertisement to one or more > prefixes. > [...] > Signed-off-by: Taylor Blau <m...@ttaylorr.com> > --- > diff --git a/t/t5410-receive-pack.sh b/t/t5410-receive-pack.sh > @@ -44,4 +44,15 @@ test_expect_success 'with core.alternateRefsCommand' ' > +test_expect_success 'with core.alternateRefsPrefixes' ' > + test_config -C fork core.alternateRefsPrefixes "refs/tags" && > + cat >expect <<-EOF && > + $(git rev-parse one) .have > + $(git rev-parse three) .have > + $(git rev-parse two) .have > + EOF
It's probably a matter of taste as to which is more readable, but this entire "cat <<EOF" block could be replaced with a simple one-liner: printf "%s .have\n" $(git rev-parse one three two) >expect && Same comment applies to previous patch, as well. > + printf "0000" | git receive-pack fork | extract_haves >actual && > + test_cmp expect actual > +'