Attention is currently required from: daniel, laforge, pespin.

lynxis lazus has posted comments on this change by lynxis lazus. ( 
https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007?usp=email )

Change subject: TCAP: Refactoring unroutable messages into own function
......................................................................


Patch Set 2:

(4 comments)

File src/tcap_as_loadshare.c:

https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007/comment/87db6544_c09cce16?usp=email
 :
PS2, Line 458: the message will be paths.
> what do you mean by "the message will be paths"?  I don't understand what 
> this is supposed to say.
Done


https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007/comment/445464c7_6fc8ed79?usp=email
 :
PS2, Line 466: static int asp_loadshare_tcap_unroutable(struct osmo_ss7_asp 
**rasp,
> asp_loadshare_tcap_unroutable_fallback() may be more descriptive. […]
fallback will be used by the DPC routing. I've renamed it to 
asp_loadshare_tcap_handle_unroutable


https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007/comment/c03bd5cf_e54137b7?usp=email
 :
PS2, Line 608:                                  rate_ctr_inc2(as->ctrg, 
SS7_AS_CTR_TCAP_ASP_FALLBACK);
> AFAIU this patch could be reduce to only adding the following line here: […]
no, because you also have to set the rc code. In general this function needs to 
be refactored. it is far to long and complex.

I've refactored some of the parts. But still this function would need a 
refactoring


https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007/comment/9aa931d1_c8ed9442?usp=email
 :
PS2, Line 636:                                  rate_ctr_inc2(as->ctrg, 
SS7_AS_CTR_TCAP_ASP_FALLBACK);
> AFAIU this patch could be reduce to only adding the following line here: […]
see above.



--
To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/43007?usp=email
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings?usp=email

Gerrit-MessageType: comment
Gerrit-Project: libosmo-sigtran
Gerrit-Branch: master
Gerrit-Change-Id: Ib4d114273423730418458767d17b11de9bd815d4
Gerrit-Change-Number: 43007
Gerrit-PatchSet: 2
Gerrit-Owner: lynxis lazus <[email protected]>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: daniel <[email protected]>
Gerrit-Reviewer: pespin <[email protected]>
Gerrit-CC: laforge <[email protected]>
Gerrit-Attention: laforge <[email protected]>
Gerrit-Attention: pespin <[email protected]>
Gerrit-Attention: daniel <[email protected]>
Gerrit-Comment-Date: Sat, 08 Aug 2026 12:33:48 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <[email protected]>
Comment-In-Reply-To: pespin <[email protected]>

Reply via email to