Attention is currently required from: dexter. laforge has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/pysim/+/42734?usp=email )
Change subject: card_key_provider: move boiler-plate code into helper functions ...................................................................... Patch Set 1: (2 comments) File pySim/card_key_provider.py: https://gerrit.osmocom.org/c/pysim/+/42734/comment/a171cd51_581e4a6c?usp=email : PS1, Line 337: def argparse_add_card_key_provider_args(arg_parser: argparse.ArgumentParser): to be consistent with other methods I would call it card_key_provider_argparse_add_args or something like that. Then all methods have the same prefix https://gerrit.osmocom.org/c/pysim/+/42734/comment/e78c1b9e_8d4d5e12?usp=email : PS1, Line 344: init_card_key_provider likewise here I'd call it card_key_provider_init similar to card_key_provider_{get,get_field} above -- To view, visit https://gerrit.osmocom.org/c/pysim/+/42734?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I6d095cbb644e608f4a751a1d0749b1484cdc781d Gerrit-Change-Number: 42734 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <[email protected]> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: laforge <[email protected]> Gerrit-Attention: dexter <[email protected]> Gerrit-Comment-Date: Thu, 07 May 2026 19:13:45 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No
