Attention is currently required from: fixeria. laforge has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/pysim/+/42375?usp=email )
Change subject: global_platform: fix store_data() returning last chunk only ...................................................................... Patch Set 1: (1 comment) File pySim/global_platform/__init__.py: https://gerrit.osmocom.org/c/pysim/+/42375/comment/6004c8f9_8be9b3f4?usp=email : PS1, Line 588: technically correct, but inside pysim we'd usually use our own h2b() function. They date back to python2 where there was no 'bytes' type, and where we had to roll our own. We can clean up the legacy at some point, but until then the code is more readable if it uses our b2h/h2b consistently. -- To view, visit https://gerrit.osmocom.org/c/pysim/+/42375?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I3e15c8004d1e366e8c3896e559656622f48bb1a2 Gerrit-Change-Number: 42375 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <[email protected]> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: laforge <[email protected]> Gerrit-Attention: fixeria <[email protected]> Gerrit-Comment-Date: Mon, 16 Mar 2026 00:25:18 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No
