Jody Garnett ha scritto:
> Thanks for the code example Andrea; I withdraw my earlier suggestion of
> combining capabilities and info.
>
> Because it is a capabilities document the "supports" is already assumed;
> so I don't think we need to step outside of java beans naming conventions.
>
> DataCapabilities capabilities = ds.getCapabilities();
> if(!capabilities.isCreateSchema()) {
>
> ...
>
> }
>
> I do see the naming trouble in both cases; capabilities
Erk, isCreateSchema() means nothing to me, seems like an unfinished
question.
I can go for isCreateSchemaSupported() if you want to use javabean
conventions.
Cheers
Andrea
--
Andrea Aime
OpenGeo - http://opengeo.org
Expert service straight from the developers.
------------------------------------------------------------------------------
_______________________________________________
Geotools-devel mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/geotools-devel