On Saturday 15 June 2013 04:39:10 Vadim A. Misbakh-Soloviov wrote:
> # @DESCRIPTION:
> # Unpack nixstaller generated files

needs a period at the end.  content in @DESCRIPTION is normalized.

> # They're shell scripts with the blob package tagged onto
> # the end of the archive. In the blob placed tarballs with
> # actual content.

"They're shell scripts with a tarball appended to them."

> # Please note, if you need additional dependecies make sure to unpack
> subarch
> # archive as first argument.

no idea what this means

> nixstaller_unpack() {

this does not follow the API naming convention ("unpack" comes first)

>         local unpack_files="$@"

this doesn't work.  you normalized the input into a string.  just inline the 
"$@" below.  or don't specify it at all ... this does the same thing (albeit, 
correctly):
        local src
        for src ; do

>                 unpack_banner "$i"
>                 # Make sure that file exists
>                 [[ -f "./$i" ]] && (
>                         local type=$(file -b ${i})
>                         case ${type} in
>                                 data)
>                                         tar -xJf "./$i"

why doesn't the bzip2 detect as bzip2 ?

>                                         ;;
>                                 gzip*)
>                                         tar -xzf "./$i"
>                                         ;;
>                         esac
>                 ) || die "Failed to unpack $i"

the subshell should go away -- you don't even need it:
        [[ $? -eq 0 ]] || die ...

i wish we could merge with the file detection in unpack_makeself somehow
-mike

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply via email to