On Sunday, August 22, 2010 17:32:11 Tomáš Chvátal wrote: > Dne 22.8.2010 23:18, Mike Frysinger napsal(a): > > On Sunday, August 22, 2010 17:10:32 Tomáš Chvátal wrote: > >> Dne 22.8.2010 23:06, Mike Frysinger napsal(a): > >>>> scons_use() > >>> > >>> keep the use_xxx style ... so rename it to "use_scons()" > >> > >> Hmm we use > >> cmake-utils_use_* > >> > >> i think use_cmake-utils-* > >> > >> also if renamed to cmake_use-* it would look more sane than use_cmake-* > >> > >> but if we make agreement other way we can replace it in cmake utils > >> quite easily :) > > > > changing eclass style to match the older-than-PMS style sounds more > > feasible. so i'd go with use_cmake-xxx. > > Do we have some poll capabilites only for devs? Something on forums?
i think we only have the forums > We can do either way and provide backcompat -> not so hard :) So i would > leave decision to the peepz. > > I dont care whether i use cmake-utils_use_enable or use_cmake_enable :) so we're clear, lemme phrase it this way: use_enable/use_with/use_xxx isnt changing. whether you choose to rename the cmake eclasses to follow the existing standard is up to you. personally, i think "use_cmake_enable" makes the most sense (or dare i suggest "use_enable_cmake" ...). transitional backwards compat shouldnt be hard. ewarn should dump to stderr which means you should be able to use it in existing functions without breaking people. -mike
signature.asc
Description: This is a digitally signed message part.
