Duncan wrote: > I believe that's the way it is now, yes. Thus what we're proposing would > simply keep the legacy meaning for world (and system) as they are, while > @world (and @system) would refer to the specific sets. > > Now that it has been suggested, I do believe that's the simplest way to > handle it, since it would involve no change at all for the existing > words.
One could avoid the confusion about world != @world completely, if one would simply rename @world into e.g. @worldfile Then one could define without any ambiguity world = @world = @worldfile + @system (and of course, one should then let @system not be a @worldfile candidate, at least by default). I am aware that currently @world is already implemented, but only in testing portage and probably not too many user scripts have been converted to this already (resp. _if_ they have been converted, they have most probably been converted from "world" to "@world @system" which would not harm either).