On 20:40 Mon 24 Sep , Alin Nastac (mrness) wrote:
> mrness 07/09/24 20:40:54
>
> Modified: dspam-web-3.8.0.ebuild ChangeLog
> Log:
> Die in pkg_setup if dev-perl/GD has been installed without png USE flag
> (#193662). Update patches tarball to match the one used in latest
> mail-filter/dspam version.
> (Portage version: 2.1.3.9)
> - mirror://gentoo/dspam-${PV}-patches-20070624.tar.gz"
> + mirror://gentoo/dspam-${PV}-patches-20070909.tar.gz"
It might increase readability and decrease maintenance to pull this date
out into a separate variable.
> + local use_errors=0
> + if built_with_use "mail-filter/dspam" user-homedirs; then
> + echo
> + eerror "The DSPAM web interface requires that mail-filter/dspam
> be installed without user-homedirs USE flag."
> eerror "Please disable this flag and re-emerge dspam."
> - die "Incompatible mail-filter/dspam installation"
> + use_errors=$[${use_errors} + 1]
> + fi
> + if ! built_with_use "dev-perl/GD" png; then
> + echo
> + eerror "The DSPAM web interface requires that dev-perl/GD be
> installed with png USE flag."
> + eerror "Please enable this flag and re-emerge GD."
> + use_errors=$[${use_errors} + 1]
> fi
> + [ ${use_errors} -gt 0 ] && die "Dependency installed with incompatible
> USE flags"
You could use C-style syntax here:
(( use_errors++ ))
I find it a bit more readable.
Thanks,
Donnie
--
[EMAIL PROTECTED] mailing list