https://gcc.gnu.org/g:0c4a95e9f51a4d7d68574579afe6de9dcea58db2
commit r14-10642-g0c4a95e9f51a4d7d68574579afe6de9dcea58db2 Author: GCC Administrator <gccadmin@gcc.gnu.org> Date: Thu Sep 5 00:22:17 2024 +0000 Daily bump. Diff: --- gcc/ChangeLog | 53 +++++++++++++++++++++++++++ gcc/DATESTAMP | 2 +- gcc/testsuite/ChangeLog | 24 +++++++++++++ libstdc++-v3/ChangeLog | 96 +++++++++++++++++++++++++++++++++++++++++++++++++ lto-plugin/ChangeLog | 19 ++++++++++ 5 files changed, 193 insertions(+), 1 deletion(-) diff --git a/gcc/ChangeLog b/gcc/ChangeLog index a494e6dc39a..8bc41ae0aaa 100644 --- a/gcc/ChangeLog +++ b/gcc/ChangeLog @@ -1,3 +1,56 @@ +2024-09-04 Andrew Carlotti <andrew.carlo...@arm.com> + + PR target/112108 + * config/aarch64/aarch64-builtins.cc (handle_arm_acle_h): Remove + feature check at initialisation. + (aarch64_general_check_builtin_call): Check ls64 intrinsics. + * config/aarch64/arm_acle.h: (data512_t) Make always available. + +2024-09-04 Andrew Carlotti <andrew.carlo...@arm.com> + + PR target/112108 + * config/aarch64/aarch64-builtins.cc (aarch64_init_memtag_builtins): + Define intrinsic names directly. + (aarch64_general_init_builtins): Move memtag intialisation... + (handle_arm_acle_h): ...to here, and remove feature check. + (aarch64_general_check_builtin_call): Check memtag intrinsics. + * config/aarch64/arm_acle.h (__arm_mte_create_random_tag) + (__arm_mte_exclude_tag, __arm_mte_ptrdiff) + (__arm_mte_increment_tag, __arm_mte_set_tag, __arm_mte_get_tag): + Remove. + +2024-09-04 Andrew Carlotti <andrew.carlo...@arm.com> + + PR target/112108 + * config/aarch64/aarch64-builtins.cc (aarch64_init_tme_builtins): + Define intrinsic names directly. + (aarch64_general_init_builtins): Move tme initialisation... + (handle_arm_acle_h): ...to here, and remove feature check. + (aarch64_general_check_builtin_call): Check tme intrinsics. + * config/aarch64/arm_acle.h (__tstart, __tcommit, __tcancel) + (__ttest): Remove. + (_TMFAILURE_*): Define unconditionally. + +2024-09-04 Andrew Carlotti <andrew.carlo...@arm.com> + + * config/aarch64/aarch64-sve-builtins.cc (check_builtin_call) + (expand_builtin): Update calls to the below. + (report_missing_extension, report_missing_registers) + (check_required_extensions): Move out of aarch64_sve namespace, + rename, and move into... + * config/aarch64/aarch64-builtins.cc (aarch64_report_missing_extension) + (aarch64_report_missing_registers) + (aarch64_check_required_extensions) ...here. + * config/aarch64/aarch64-protos.h (aarch64_check_required_extensions): + Add prototype. + +2024-09-04 Andrew Carlotti <andrew.carlo...@arm.com> + + * config/aarch64/aarch64-sve-builtins.cc + (check_required_registers): Remove target check and rename to... + (report_missing_registers): ...this. + (check_required_extensions): Refactor. + 2024-09-03 Haochen Jiang <haochen.ji...@intel.com> * config/i386/avx512fp16intrin.h diff --git a/gcc/DATESTAMP b/gcc/DATESTAMP index 301a37d563d..c8bedcac256 100644 --- a/gcc/DATESTAMP +++ b/gcc/DATESTAMP @@ -1 +1 @@ -20240904 +20240905 diff --git a/gcc/testsuite/ChangeLog b/gcc/testsuite/ChangeLog index 56d4aad7f9b..6f349aee248 100644 --- a/gcc/testsuite/ChangeLog +++ b/gcc/testsuite/ChangeLog @@ -1,3 +1,27 @@ +2024-09-04 Andrew Carlotti <andrew.carlo...@arm.com> + + PR target/112108 + * gcc.target/aarch64/acle/ls64_guard-1.c: New test. + * gcc.target/aarch64/acle/ls64_guard-2.c: New test. + * gcc.target/aarch64/acle/ls64_guard-3.c: New test. + * gcc.target/aarch64/acle/ls64_guard-4.c: New test. + +2024-09-04 Andrew Carlotti <andrew.carlo...@arm.com> + + PR target/112108 + * gcc.target/aarch64/acle/memtag_guard-1.c: New test. + * gcc.target/aarch64/acle/memtag_guard-2.c: New test. + * gcc.target/aarch64/acle/memtag_guard-3.c: New test. + * gcc.target/aarch64/acle/memtag_guard-4.c: New test. + +2024-09-04 Andrew Carlotti <andrew.carlo...@arm.com> + + PR target/112108 + * gcc.target/aarch64/acle/tme_guard-1.c: New test. + * gcc.target/aarch64/acle/tme_guard-2.c: New test. + * gcc.target/aarch64/acle/tme_guard-3.c: New test. + * gcc.target/aarch64/acle/tme_guard-4.c: New test. + 2024-09-03 Haochen Jiang <haochen.ji...@intel.com> * gcc.target/i386/avx512fp16-vfpclassph-1c.c: New test. diff --git a/libstdc++-v3/ChangeLog b/libstdc++-v3/ChangeLog index f05ec03c85e..fa511f0dc09 100644 --- a/libstdc++-v3/ChangeLog +++ b/libstdc++-v3/ChangeLog @@ -1,3 +1,99 @@ +2024-09-04 Jonathan Wakely <jwak...@redhat.com> + + Backported from master: + 2024-09-03 Jonathan Wakely <jwak...@redhat.com> + + * src/c++17/fs_ops.cc (auto_win_file_handle): Add error_code& + member and set it if CreateFileW or GetFileInformationByHandle + fails. + (fs::equiv_files) [_GLIBCXX_FILESYSTEM_IS_WINDOWS]: Simplify + control flow. + (fs::hard_link_count) [_GLIBCXX_FILESYSTEM_IS_WINDOWS]: Clear ec + on success. + * testsuite/27_io/filesystem/operations/hard_link_count.cc: + Check error handling. + +2024-09-04 Jonathan Wakely <jwak...@redhat.com> + + Backported from master: + 2024-07-30 Jonathan Wakely <jwak...@redhat.com> + + * src/c++17/fs_ops.cc (auto_win_file_handle): Change constructor + parameter from const path& to const wchar_t*. + (fs::equiv_files): New function. + (fs::equivalent): Use equiv_files. + * src/filesystem/ops-common.h (fs::equiv_files): Declare. + (do_copy_file): Use equiv_files. + * src/filesystem/ops.cc (fs::equiv_files): Define. + (fs::copy, fs::equivalent): Use equiv_files. + * testsuite/27_io/filesystem/operations/copy.cc: Test + overwriting directory contents recursively. + * testsuite/27_io/filesystem/operations/copy_file.cc: Test + overwriting existing files. + +2024-09-04 Lennox Shou Hao Ho <lennox...@gmail.com> + + Backported from master: + 2024-07-30 Lennox Shou Hao Ho <lennox...@gmail.com> + + PR libstdc++/113663 + * src/c++17/fs_ops.cc (fs::equivalent): Moved helper class + auto_handle to anonymous namespace as auto_win_file_handle. + (fs::hard_link_count): Changed Windows implementation to use + information provided by GetFileInformationByHandle which is more + reliable. + * testsuite/27_io/filesystem/operations/hard_link_count.cc: New + test. + +2024-09-04 Jonathan Wakely <jwak...@redhat.com> + + Backported from master: + 2024-09-03 Jonathan Wakely <jwak...@redhat.com> + + PR libstdc++/116549 + * include/bits/stl_iterator.h (disable_sized_sentinel_for): + Define specialization for two move_iterator types, as per LWG + 3736. + * testsuite/24_iterators/move_iterator/lwg3736.cc: New test. + +2024-09-04 Dhruv Chawla <dhr...@nvidia.com> + + Backported from master: + 2024-09-03 Dhruv Chawla <dhr...@nvidia.com> + + * include/std/deque: Define macro + __glibcxx_want_allocator_traits_is_always_equal. + * include/std/forward_list: Likewise. + * include/std/list: Likewise. + * include/std/map: Likewise. + * include/std/scoped_allocator: Likewise. + * include/std/set: Likewise. + * include/std/string: Likewise. + * include/std/unordered_map: Likewise. + * include/std/unordered_set: Likewise. + * include/std/vector: Likewise. + * testsuite/20_util/headers/memory/version.cc: New test. + * testsuite/20_util/scoped_allocator/version.cc: Likewise. + * testsuite/21_strings/headers/string/version.cc: Likewise. + * testsuite/23_containers/deque/version.cc: Likewise. + * testsuite/23_containers/forward_list/version.cc: Likewise. + * testsuite/23_containers/list/version.cc: Likewise. + * testsuite/23_containers/map/version.cc: Likewise. + * testsuite/23_containers/set/version.cc: Likewise. + * testsuite/23_containers/unordered_map/version.cc: Likewise. + * testsuite/23_containers/unordered_set/version.cc: Likewise. + * testsuite/23_containers/vector/version.cc: Likewise. + +2024-09-04 Jonathan Wakely <jwak...@redhat.com> + + Backported from master: + 2024-08-21 Jonathan Wakely <jwak...@redhat.com> + + PR libstdc++/116381 + * include/std/variant (variant): Fix conditions for + static_assert to match the spec. + * testsuite/20_util/variant/types_neg.cc: New test. + 2024-08-03 Jonathan Wakely <jwak...@redhat.com> Backported from master: diff --git a/lto-plugin/ChangeLog b/lto-plugin/ChangeLog index 780225c49de..c4a59473f67 100644 --- a/lto-plugin/ChangeLog +++ b/lto-plugin/ChangeLog @@ -1,3 +1,22 @@ +2024-09-04 H.J. Lu <hjl.to...@gmail.com> + + Backported from master: + 2024-08-23 H.J. Lu <hjl.to...@gmail.com> + + PR lto/116361 + * lto-plugin.c (claim_file_handler_v2): Don't check obj.found + for the offload section. + +2024-09-04 H.J. Lu <hjl.to...@gmail.com> + + Backported from master: + 2024-08-22 H.J. Lu <hjl.to...@gmail.com> + + PR lto/116361 + * lto-plugin.c (claim_file_handler_v2): Rename claimed to + can_be_claimed. Include the LTO object only if it is known to + be included in link output. + 2024-08-01 Release Manager * GCC 14.2.0 released.