On 05/05/14 11:37, Richard Biener wrote:
Well, I hope that Andrew doesn't do without a namespace (and I still
don't believe in what he tries to achieve without laying proper ground-work
throughout the compiler). With a namespace gimple we can use
gimple::stmt.
namespaces, while nice, aren't going to solve all these issues. While I
think we can get a good separation between gimple and the rest of the
world, I suspect namespaces aren't going to help much with the statement
vs expression vs type issues.
Ultimately I suspect we're not going to have too many places where we
can stick a "using namespace gimple-whatever", but time will tell.
Agreed on that, btw. But switch_ can't be the answer either. Maybe
swidch (similar do klass) or swjdch. Or swtch. I like swtch the best
(similar to stmt).
As David pointed out there's several others that map to keywords. I'd
rather set a standard here across the project so that we don't have
folks using gto for goto, others using goto_, _goto, whatever. While
swtch works well, I don't think the other examples work nearly as well.
Thus some kind of prefix/suffix seems better to me (though I'm sure my
eyes will bleed as a result of looking at those objects).
jeff