On 02/24/2014 02:32 AM, Adam Butcher wrote:
+static bool function_being_declared_is_template_p (cp_parser* parser)
Function name should be at the beginning of the next line.
- if (scope->kind != sk_template_parms) + if (scope->kind != sk_template_parms + || !function_being_declared_is_template_p (parser))
Is there a reason not to move the scope->kind check into the new function? Jason