> > > - return (gimple_omp_subcode (g) & GF_OMP_FOR_COMBINED) != 0; > > + return (gimple_omp_for_kind (g) == GF_OMP_FOR_COMBINED); > > I don't really know this code, but this change seems unlikely to be correct. > Can you explain it?
I really need help on this. I need a new enum type (I call this: GF_OMP_FOR_KIND_CILKFOR) that I need to mark _Cilk_for so that I can differentiate it. Can someone please help me pick a new one or explain to me how the enum gf_mask is structured? I am not understanding the header comment fully... Thanks, Balaji V. Iyer.