Hi,
On 03/29/2013 04:59 PM, Gabriel Dos Reis wrote:
This patch introduces the predicate VAR_P and use it in place of direct
TREE_CODE (t) == VAR_DECL
It improves readability and makes predicates easier to follow.
Tested on an x86_64-suse-linux. Applying to trunk.
Thanks.
Do you think it would also make sense to consistently use in C++
front-end TYPE_PTR_P instead of TREE_CODE (t) == POINTER_TYPE? It's
something I noticed a while ago when I cleaned-up predicated related to
pointers and occurred to me again now that you are doing some of this
kind of work. If you like I can do this bit.
Thanks,
Paolo.