On Fri, Jul 17, 2026 at 1:40 PM Takayuki 'January June' Suwa
<[email protected]> wrote:
>
> The successive modifications made to 'xtensa_legitimize_address()' have
> worsened the readability of the code, and the modifications themselves
> are difficult to understand.
>
> Therefore, this patch resolves these issues by completely rewriting the
> function to make its intent clear.
>
> gcc/ChangeLog:
>
>         * config/xtensa/xtensa.cc (xtensa_legitimize_address):
>         Completely rewrite it into an equivalent but more easily under-
>         standable description.
> ---
>   gcc/config/xtensa/xtensa.cc | 104 +++++++++++++++++++-----------------
>   1 file changed, 55 insertions(+), 49 deletions(-)

Regtested for target=xtensa-linux-uclibc, no new regressions.
Committed whole series to master.

-- 
Thanks.
-- Max

Reply via email to