Hi Joseph, On Fri, May 16, 2025 at 07:13:15PM +0200, Alejandro Colomar wrote: > On Fri, May 16, 2025 at 05:01:36PM +0000, Joseph Myers wrote: > > On Fri, 16 May 2025, Alejandro Colomar wrote: > > > > > Hmmm, I've been trying to find a compromise between readability and > > > simplicity, and I think I have something. I've seen some tests that > > > define assert() themselves. I like assert(3) because it's more > > > readable compared to a conditional plus abort(3). > > > > > > So, how do you feel about the following change? > > > > > > diff --git i/gcc/testsuite/gcc.dg/countof-stdcountof.c > > > w/gcc/testsuite/gcc.dg/countof-stdcountof.c > > > index a7fe4079c69..2fb0c6306ef 100644 > > > --- i/gcc/testsuite/gcc.dg/countof-stdcountof.c > > > +++ w/gcc/testsuite/gcc.dg/countof-stdcountof.c > > > @@ -3,8 +3,7 @@ > > > > > > #include <stdcountof.h> > > > > > > -#undef NDEBUG > > > -#include <assert.h> > > > +#define assert(e) ((e) ? (void) 0 : __builtin_abort ()) > > > > Yes, I think that's a reasonable way for a test to do its assertions with > > assert syntax but without depending unnecessarily on libc headers. > > If there are any other issues, I'll apply that change for v23. If this > is the only one, would you mind amending yourself with that while > committing? Thanks!
Could you please clarify if I need to do anything or if this is already scheduled for review when you have some time? Also please clarify if you're okay with amending that or if you prefer that I send v23. TBH, I was a bit frustrated by the process when -Wunterminated-string-initialization was reviewed, because nobody would take the patch nor reply, and it was only when Martin asked me about it that I said I had no idea about who should commit it that he committed it. A bit more communication would help. :-) Have a lovely day! Alex -- <https://www.alejandro-colomar.es/>
signature.asc
Description: PGP signature