Hi,
Thomas Schwinge wrote:
On 2021-11-06T00:51:59+0800, Chung-Lin Tang <clt...@codesourcery.com> wrote:
On 2021/6/24 11:55 PM, Jakub Jelinek wrote:
On Fri, May 14, 2021 at 09:20:25PM +0800, Chung-Lin Tang wrote:
+ OMP_CLAUSE_MAP_IMPLICIT_P (clause) = 1;
As Thomas mentioned, there is now also OMP_CLAUSE_MAP_IMPLICIT that means
something different: [...]
Having OMP_CLAUSE_MAP_IMPLICIT and OMP_CLAUSE_MAP_IMPLICIT_P would be too
confusing. [...]
I have changed the name to OMP_CLAUSE_MAP_RUNTIME_IMPLICIT_P, [...]
...
--- a/gcc/tree-pretty-print.cc
+++ b/gcc/tree-pretty-print.cc
@@ -1172,7 +1172,7 @@ dump_omp_clause (pretty_printer *pp, tree clause, int
spc, dump_flags_t flags)
}
if (OMP_CLAUSE_CODE (clause) == OMP_CLAUSE_MAP
&& OMP_CLAUSE_MAP_RUNTIME_IMPLICIT_P (clause))
- pp_string (pp, "[implicit]");
+ pp_string (pp, "[runtime_implicit]");
pp_right_paren (pp);
break;
There are too many 'implicit' … while I am not sure whether runtime_implicit
is really descriptive/best wording, it is consistent, avoid the ambiguity and
if one looks in depth at those dumps, one has to understand the compiler tweaks
already, e.g. by looking at the source code. In any case, nonambiguity is the
main selling point. Hence:
Sure, that's a useful improvement & LGTM!
Thanks,
Tobias