On Mon, Jul 16, 2012 at 11:03 AM, Steven Bosscher <stevenb....@gmail.com> wrote: > On Mon, Jul 16, 2012 at 10:53 AM, Richard Guenther > <richard.guent...@gmail.com> wrote: >> Maybe we should rename EDGE_CAN_FALLTHRU to EDGE_PLF_1 >> and have a #define in bb-reorder.c then? Other passes might use >> it for their pass-local handling then and would not be content to set/unset >> it. > > I intend to do a lot more cleanups on the edge and basic block flags > (that depends on the dumpfile.h patch, eagerly awaiting your ACK or > comments ;-).
See your inbox ;) > For EDGE_CAN_FALLTHRU I was more thinking of a pointer map or an > sbitmap on an edge list, tbd. Or, like you suggest, make it a flag > available for passes to use. That would also help for a few other > flags (EDGE_LOOP_EXIT, EDGE_EXECUTABLE, ...). Indeed - I prefer the pass-specific flags approach, we seem to have this almost everywhere. Richard. > Ciao! > Steven