We expect: flw ... vmfxx.vf For simplicity of supporting vx and vf, two refactors completed first. 1. remove eqne pattern; any special case or reason for eqne when first added? 2. refactor duplicate code.
demin.han (5): RISC-V: Remove float vector eqne pattern RISC-V: Refactor expand_vec_cmp RISC-V: Support vmfxx.vf for autovec comparison of vec and imm RISC-V: Remove integer vector eqne pattern RISC-V: Support vmsxx.vx for autovec comparison of vec and imm gcc/config/riscv/autovec.md | 2 +- gcc/config/riscv/predicates.md | 4 +- gcc/config/riscv/riscv-protos.h | 2 +- gcc/config/riscv/riscv-string.cc | 4 +- gcc/config/riscv/riscv-v.cc | 94 ++--- .../riscv/riscv-vector-builtins-bases.cc | 7 - gcc/config/riscv/riscv.cc | 2 +- gcc/config/riscv/vector.md | 365 +----------------- .../riscv/rvv/autovec/cmp/vcond-1.c | 48 ++- 9 files changed, 105 insertions(+), 423 deletions(-) -- 2.43.2