> > > > /* Nonzero for FUNCTION_DECL means that this decl is a non-static > > > > - member function. */ > > > > + member function, use DECL_IOBJ_MEMBER_FUNC_P instead. */ > > > > #define DECL_NONSTATIC_MEMBER_FUNCTION_P(NODE) \ > > > > (TREE_CODE (TREE_TYPE (NODE)) == METHOD_TYPE) > > > > > > > > +/* Nonzero for FUNCTION_DECL means that this decl is an implicit object > > > > + member function. */ > > > > +#define DECL_IOBJ_MEMBER_FUNC_P(NODE) \ > > > > + (TREE_CODE (TREE_TYPE (NODE)) == METHOD_TYPE) > > > > > > I was thinking to rename DECL_NONSTATIC_MEMBER_FUNCTION_P rather than > > > add a new, equivalent one. And then go through all the current uses of > > > the old macro to decide whether they mean IOBJ or OBJECT. > > > > I figure it would be easier to make that transition if there's a clear > > line between old versus new. To be clear, my intention is for the old > > macro to be removed once all the uses of it are changed over to the new > > macro. I can still remove it for the patch if you like but having both > > and removing the old one later seems better to me. > > > Hmm, I think changing all the uses is a necessary part of this change. > I suppose it could happen before the main patch, if you'd prefer, but it > seems more straightforward to include it. >
I had meant to reply to this as well but forgot, I agree that it's likely necessary but I've only been changing them as I come across things that don't work right rather than trying to evaluate them through the code. Making changes to them without having a test case that demonstrates that the case is definitely being handled incorrectly is risky, especially for me since I don't have a full understanding of the code base. I would rather only change ones that are evidently wrong, and defer the rest to someone else who knows the code base better. With that said, I have been neglecting replacing uses of the old macro, but I now realize that's just creating more work for whoever is evaluating the rest of them. Going forward I will make sure I replace the old macro when I am fairly certain it should be. Alex