Use No_Uint to indicate "unknown" or "not yet known" for various fields
whose type is Uint, instead of using Uint_0. Otherwise Uint_0 could be
ambiguous -- it could also mean "value is known, and is zero". This
patch does not fix all bugs in this area, but fixes most of them, and
adds assertions that should prevent new ones.

Work around unset sizes:
Previous changes caused several latent bugs to become crashes in e.g.
gnat-llvm, because some size-related fields aren't set. Previously, unset
fields defaulted to Uint_0, but now they default to No_Uint, which crashes
on most operations, such as "=" and ">". This patch turns them back into latent
bugs by checking for No_Uint explictly.

Misc cleanup.

Tested on x86_64-pc-linux-gnu, committed on trunk

gcc/ada/

        * atree.ads: Comment improvements. How is a "completely new
        node" different from a "new node"? Document default values
        corresponding to field types.
        * exp_ch7.adb (Process_Tagged_Type_Declaration): Use
        higher-level Scope_Depth instead of Scope_Depth_Value.  Remove
        confusing comment: not clear what a "true" library level package
        is.
        * uintp.adb (Image_Out): Print No_Uint in a more readable way.
        * gen_il-gen.adb, gen_il-gen-gen_entities.adb,
        gen_il-gen-gen_nodes.adb, gen_il-types.ads: Tighten up the
        subtypes of fields whose type is Uint, where possible; use
        more-constrained subtypes such as Unat.
        * einfo-utils.adb, einfo-utils.ads, exp_attr.adb,
        exp_ch3.adb, exp_intr.adb, exp_unst.adb, exp_util.adb,
        freeze.adb, repinfo.adb, sem.adb, sem_ch12.adb, sem_ch13.adb,
        sem_ch3.adb, sem_ch8.adb, sem_util.adb, sprint.adb, treepr.adb:
        No longer use Uint_0 to indicate "unknown" or "not yet known"
        for various fields whose type is Uint. Use No_Uint for that,
        except in a small number of legacy cases that cause test
        failures. Protect many queries of such fields with calls to
        Known_... functions. Improve comments.
        * exp_aggr.adb: Likewise.
        (Is_OK_Aggregate): Check whether Csiz is present.
        (Aggr_Assignment_OK_For_Backend): Ensure we do not access an
        uninitialized size.
        * exp_strm.adb (Build_Elementary_Input_Call,
        Build_Elementary_Write_Call): Check whether P_Size is present.
        * cstand.adb: Leave Component_Size of Any_Composite unknown.
        Similar for RM_Size of Standard_Exception_Type.  These should
        not be used.
        * einfo.ads: Comment improvements.
        * exp_disp.ads: Minor.
        * gen_il-internals.ads, gen_il-internals.adb: Minor.
        * sinfo-utils.adb: Take advantage of full-coverage rules.
        * types.h: Minor.

Attachment: patch.diff.gz
Description: application/gzip

Reply via email to