This is required for CodePeer to use a better name for a variable, or a
constant created by GNAT.
Tested on x86_64-pc-linux-gnu, committed on trunk
gcc/ada/
* exp_util.adb (Build_Temporary): In case of an external DISCR
symbol, set the related expression for CodePeer so that a more
comprehensible message can be emitted to the user.
diff --git a/gcc/ada/exp_util.adb b/gcc/ada/exp_util.adb
--- a/gcc/ada/exp_util.adb
+++ b/gcc/ada/exp_util.adb
@@ -11656,6 +11656,7 @@ package body Exp_Util is
is
Temp_Id : Entity_Id;
Temp_Nam : Name_Id;
+ Should_Set_Related_Expression : Boolean := False;
begin
-- The context requires an external symbol : expression is
@@ -11675,6 +11676,12 @@ package body Exp_Util is
else
pragma Assert (Discr_Number > 0);
+
+ -- We don't have any intelligible way of printing T_DISCR in
+ -- CodePeer. Thus, set a related expression in this case.
+
+ Should_Set_Related_Expression := True;
+
-- Use fully qualified name to avoid ambiguities.
Temp_Nam :=
@@ -11684,6 +11691,10 @@ package body Exp_Util is
Temp_Id := Make_Defining_Identifier (Loc, Temp_Nam);
+ if Should_Set_Related_Expression then
+ Set_Related_Expression (Temp_Id, Related_Nod);
+ end if;
+
-- Otherwise generate an internal temporary
else