> gcc/ChangeLog:
> 
>         * config/sparc/sparc.c (next_active_non_empty_insn): New function
>         that returns next active non empty assembly instruction.
>         (sparc_do_work_around_errata): Use new function.

OK everywhere, modulo a couple of nits:

> +rtx_insn *
> +next_active_non_empty_insn (rtx_insn *insn)
> +{
> +  insn = next_active_insn (insn);
> +
> +  while (insn
> +      && ((GET_CODE (PATTERN (insn)) == UNSPEC_VOLATILE)

Superfluous parentheses 

> +          || (GET_CODE (PATTERN (insn)) == ASM_INPUT)

Likewise.

> +          || (USEFUL_INSN_P (insn)
> +              && (asm_noperands (PATTERN (insn))>=0)

Missing spaces around >=

> +    {
> +      insn = next_active_insn (insn);
> +    }

Superfluous curly braces, even for readability.

-- 
Eric Botcazou


Reply via email to