On 9/13/21 7:17 PM, Segher Boessenkool wrote: > On Mon, Sep 13, 2021 at 05:10:42PM -0500, Peter Bergner wrote: >> It still has "a" match_operand...for operand 0. The match_operand >> for operand 1 was what was removed. Want me to reword that as >> "Remove source match_operand." or "Remove match_operand 1." or ??? > > Ah I see, I looked with my eyes close apparently. "Remove operand 1"?
Ok, I'll use that. >> ;; We can't have integer constants in XOmode so we wrap this in an >> ;; UNSPEC_VOLATILE. >> >> ...to refer to the dummy zero for the source. Let me know what you want. > > The latter option adds information, so if you think that is useful to > have here, let's go with that? Sure will do. I'll make the above changes and the ones from my previous reply and do one last build before pushing. Thanks for the review! Peter