On Tue, Jul 27, 2021 at 04:06:49PM -0500, will schmidt wrote: > On Thu, 2021-06-17 at 10:19 -0500, Bill Schmidt via Gcc-patches wrote: > > + case RS6000_BIF_ST_ELEMREV_V1TI: > > + return (BYTES_BIG_ENDIAN ? CODE_FOR_vsx_store_v1ti > > + : CODE_FOR_vsx_st_elemrev_v1ti); > > Hmm, would it be worthy to rename one of the pair so they both match "_st_" > or "_store_" ? > > CODE_FOR_vsx_store_v1ti > CODE_FOR_vsx_st_elemrev_v1ti
"st" is not a good name. "store" would be better, and it is not like three extra characters will kill you here. But is have to be changed in the machine description of course, these are existing pattern names. Segher