Hi! On Tue, Jul 06, 2021 at 11:11:05AM +0800, HAO CHEN GUI wrote: > The patch changed matching conditions in pr81384.c and pr56605.c. > The original conditions failed to match due to mode promotion disabled.
> PR target/100952 > * gcc/testsuite/gcc.target/powerpc/pr56605.c: Change matching > conditions. > * gcc/testsuite/gcc.target/powerpc/pr81348.c: Likewise. > > diff --git a/gcc/testsuite/gcc.target/powerpc/pr56605.c > b/gcc/testsuite/gcc.target/powerpc/pr56605.c > index 29efd815adc..2b7ddbd7410 100644 > --- a/gcc/testsuite/gcc.target/powerpc/pr56605.c > +++ b/gcc/testsuite/gcc.target/powerpc/pr56605.c > @@ -11,5 +11,5 @@ void foo (short* __restrict sb, int* __restrict ia) > ia[i] = (int) sb[i]; > } > > -/* { dg-final { scan-rtl-dump-times "\\\(compare:CC > \\\((?:and|zero_extend):DI \\\(reg:\[SD\]I" 1 "combine" } } */ > +/* { dg-final { scan-rtl-dump-times "\\\(compare:CC > \\\((?:and|zero_extend):SI \\\(subreg:SI \\\(reg:\[SD\]I" 1 "combine" } } */ So, this testcase only runs on 64-bit machines (even only on lp64 configurations). But do we now always get a subreg? And, can that change again some time in the future? Writing it as /* { dg-final { scan-rtl-dump-times {\(compare:CC \((?:and|zero_extend):SI \(subreg:SI \(reg:[SD]I} 1 "combine" } } */ is easier to read btw. If you get a subreg:SI of a reg:SI here, something is wrong. And you cannot have a zero_extend:SI of anything :SI either. So what the original matched were (compare:CC (and:DI (reg:DI and (compare:CC (zero_extend:DI (reg:SI and now you want to allow a subreg:SI in that last one as well (and you do not really care what it is a subreg of, you don't check what offset anyway), so maybe just /* { dg-final { scan-rtl-dump-times {\(compare:CC \((?:and|zero_extend):(?:DI \((?:sub)?reg:[SD]I} 1 "combine" } } */ will do what you want? > --- a/gcc/testsuite/gcc.target/powerpc/pr81348.c > +++ b/gcc/testsuite/gcc.target/powerpc/pr81348.c > @@ -19,5 +19,5 @@ void d(void) > ***c = e; > } > > -/* { dg-final { scan-assembler {\mlxsihzx\M} } } */ > -/* { dg-final { scan-assembler {\mvextsh2d\M} } } */ > +/* { dg-final { scan-assembler {\mlha\M} } } */ > +/* { dg-final { scan-assembler {\mmtvsrwa\M} } } */ (This test should not test for powerpc64*-*-* but powerpc*-*-* btw, and that means it can just be left out, so just /* { dg-do compile { target lp64 } } */ and nothing more). Okay for trunk with those changes (the RE and lp64). Thanks! (Test if it works of course; I did not :-) ) Segher