Hi! On Thu, Jun 17, 2021 at 10:19:05AM -0500, Bill Schmidt wrote: > 2021-06-07 Bill Schmidt <wschm...@linux.ibm.com> > > gcc/ > * config/rs6000/rs6000-gen-builtins.c (write_bif_static_init): New > function. > (write_init_file): Call write_bif_static_init.
> + for (int j = 0; j < 3; j++) > + res[j] = (bifp->proto.restr_opnd[j] == 0 ? "RES_NONE" > + : (bifp->proto.restr[j] == RES_BITS ? "RES_BITS" > + : (bifp->proto.restr[j] == RES_RANGE ? "RES_RANGE" > + : (bifp->proto.restr[j] == RES_VALUES ? "RES_VALUES" > + : (bifp->proto.restr[j] == RES_VAR_RANGE > + ? "RES_VAR_RANGE" : "ERROR"))))); The unnecessary parens make this harder to read. Having ? on the same line as the condition but : on another is not normal style. Some "if"s would be more readable anyway? Okay for trunk. Thanks! Segher