This is to make development version string more readable, and to simplify navigation through gcc-testresults.
Currently gcc_update uses git log --pretty=tformat:%p:%t:%H to generate version string, which is somewhat excessive since conversion to git because commit hashes are now stable. Even better, gcc-git-customization.sh script provides gcc-descr alias which makes prettier version string, and thus use it instead (or just abbreviated commit hash when the alias is not available). Before: [master revision b25edf6e6fe:e035f180ebf:7094a69bd62a14dfa311eaa2fea468f221c7c9f3] After: [master r12-2331] OK for mainline? contrib/Changelog: * gcc_update: Use gcc-descr alias for revision string if it exists, or abbreviated commit hash instead. Drop "revision" from gcc/REVISION. --- contrib/gcc_update | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/contrib/gcc_update b/contrib/gcc_update index 80fac9fc995..8f712e37616 100755 --- a/contrib/gcc_update +++ b/contrib/gcc_update @@ -332,7 +332,7 @@ case $vcs_type in exit 1 fi - revision=`$GCC_GIT log -n1 --pretty=tformat:%p:%t:%H` + revision=`$GCC_GIT gcc-descr || $GCC_GIT log -n1 --pretty=tformat:%h` branch=`$GCC_GIT name-rev --name-only HEAD || :` ;; @@ -414,6 +414,6 @@ rm -f LAST_UPDATED gcc/REVISION date echo "`TZ=UTC date` (revision $revision)" } > LAST_UPDATED -echo "[$branch revision $revision]" > gcc/REVISION +echo "[$branch $revision]" > gcc/REVISION touch_files_reexec