On 3/24/21 5:44 AM, Jakub Jelinek via Gcc-patches wrote:
Hi!

I'd like to ping the
https://gcc.gnu.org/pipermail/gcc-patches/2021-March/566821.html
P1 PR99565 fix.

Marek has acked the gcc/c/ and gcc/c-family/ part of that patch, but it still
has gcc/cp/ and gcc/ parts that weren't acked.
If you have suggestions for better OEP_* flag name, I can change it.


Yes, as I said, I think changing it would be helpful.  I already
tried to make some these points in my comments on the patch but
it might help to reiterate them.

A good API name reflects the purpose of the API rather than one of
its (conceivably many) use cases.

By way of an example, when a new flag was needed to implement
-Wduplicate-branches it wasn't called OEM_DUPLICATE_BRANCHES but
OEM_LEXICOGRAPHIC.  That was a good choice of a name because it's
generic enough not to be surprising when used in other contexts.

For the same reason, when an another flag is needed to refine
the behavior of the function in a way that affects the same warning,
it too should describe the effect of the flag on the function rather
than just one possible use case.

Since the new flag determines whether or not distinct members at
the same offset are considered equal, a name that mentions MEMBER
and OFFSET might be suitable.

E.g., OEP_IGNORE_MEMBER_OFFSET or OEP_SAME_MEMBER_OFFSET (for
the converse of the first) or something like that, but hopefully
you get the idea.

Martin

Reply via email to