On Tue, Jan 26, 2021 at 12:16:14PM +0100, Richard Biener wrote: > > + /* Unless this is called during FE folding. */ > > + if (cfun > > + && (cfun->curr_properties & (PROP_trees | PROP_rtl)) == 0 > > don't you want && (cfun->curr_properties & PROP_trees) != 0?
No, PROP_trees is misnamed and it actually means GIMPLE. I could use (PROP_gimple_any | PROP_rtl) if that is more readable, PROP_trees stands for: (PROP_gimple_any | PROP_gimple_lcf | PROP_gimple_leh | PROP_gimple_lomp) but I don't think we ever have any of the latter 3 set when PROP_gimple_any is not set. Jakub