New patch uploaded with the changes.

        * i386.c (IX86_BUILTIN_CPU_IS_AMDFAM15H_BDVER1): New enum value.
        (IX86_BUILTIN_CPU_IS_AMDFAM15H_BDVER2): New enum value.
        (IX86_BUILTIN_CPU_IS_AMDFAM10H): Rename IX86_BUILTIN_CPU_IS_AMDFAM10.
        (IX86_BUILTIN_CPU_IS_AMDFAM10H_BARCELONA): Rename
IX86_BUILTIN_CPU_IS_AMDFAM10_BARCELONA.
        (IX86_BUILTIN_CPU_IS_AMDFAM10H_SHANGHAI): Rename
IX86_BUILTIN_CPU_IS_AMDFAM10_SHANGHAI.
        (IX86_BUILTIN_CPU_IS_AMDFAM10H_ISTANBUL): Rename
IX86_BUILTIN_CPU_IS_AMDFAM10_ISTANBUL.
        (fold_builtin_cpu): Process IX86_BUILTIN_CPU_IS_AMDFAM15H_BDVER1
        and IX86_BUILTIN_CPU_IS_AMDFAM15H_BDVER2.
        (M_AMDFAM10H): Rename M_AMDFAM10.
        (M_AMDFAM10H_BARCELONA): Rename M_AMDFAM10_BARCELONA.
        (M_AMDFAM10H_SHANGHAI): Rename M_AMDFAM10_SHANGHAI.
        (M_AMDFAM10H_ISTANBUL): Rename M_AMDFAM10_ISTANBUL.
        (ix86_init_platform_type_builtins): Make new builtins
__builtin_cpu_is_amdfam15_bdver1
        and __builtin_cpu_is_amdfam15_bdver2.
        (ix86_expand_builtin): Expand IX86_BUILTIN_CPU_IS_AMDFAM15_BDVER1 and
        IX86_BUILTIN_CPU_IS_AMDFAM15_BDVER2.
        * testsuite/gcc.target/builtin_target.c (fn1): Call new builtins.

        * i386-cpuinfo.c (__cpu_is_amdfam15h_bdver1): New member in __cpu_model
struct.
        (__cpu_is_amdfam15h_bdver2): New member in __cpu_model struct.
        (__cpu_model): Rename __cpu_is_amdfam10 to __cpu_is_amdfam10h.
        Rename __cpu_is_amdfam10_barcelona to __cpu_is_amdfam10h_barcelona.
        Rename __cpu_is_amdfam10_shanghai to __cpu_is_amdfam10h_shanghai.
        Rename __cpu_is_amdfam10_istanbul to __cpu_is_amdfam10h_istanbul.
        (get_amd_cpu): Check for family 15h processors.
        (cpu_indicator_init): Adjust model and family for AMD processors.
        Refactor code.


Thanks,
-Sri.

On 2012/01/11 00:05:01, davidxl wrote:
http://codereview.appspot.com/5535046/diff/1/gcc/config/i386/i386.c
File gcc/config/i386/i386.c (right):


http://codereview.appspot.com/5535046/diff/1/gcc/config/i386/i386.c#newcode26032
gcc/config/i386/i386.c:26032: +    M_AMDFAM15,
Maybe better to change 10 to 10H, and 15 to 15H in the name as the
number is
hex.

Why not split the enum for family 15h into M_AMDFAM15H_BDVER1 and
.._BVER2?


http://codereview.appspot.com/5535046/diff/1/libgcc/config/i386/i386-cpuinfo.c
File libgcc/config/i386/i386-cpuinfo.c (right):


http://codereview.appspot.com/5535046/diff/1/libgcc/config/i386/i386-cpuinfo.c#newcode102
libgcc/config/i386/i386-cpuinfo.c:102: break;
No family15h model encoding?



http://codereview.appspot.com/5535046/

Reply via email to