Thanks for doing this. In addition to what Segher said: Jojo R <jiejie_r...@c-sky.com> writes: > gcc/ChangeLog: > > * genemit.c (main): Print 'split line'. > * Makefile.in (insn-emit.c): Define split count and file > > --- > gcc/Makefile.in | 15 +++++++++ > gcc/genemit.c | 87 ++++++++++++++++++++++++++++--------------------- > 2 files changed, 64 insertions(+), 38 deletions(-) > > diff --git a/gcc/Makefile.in b/gcc/Makefile.in > index 79e854aa938..08e4aa7ef6f 100644 > --- a/gcc/Makefile.in > +++ b/gcc/Makefile.in > @@ -1258,6 +1258,17 @@ ANALYZER_OBJS = \ > # We put the *-match.o and insn-*.o files first so that a parallel make > # will build them sooner, because they are large and otherwise tend to be > # the last objects to finish building. > + > +# target overrides > +-include $(tmake_file) > + > +INSN-GENERATED-SPLIT-NUM ?= 0 > +insn-generated-split-num = $(shell expr $(INSN-GENERATED-SPLIT-NUM) + 1) > + > +insn-emit-split-c = $(foreach o, $(shell for i in > {1..$(insn-generated-split-num)}; do echo $$i; done), insn-emit$(o).c)
The {a..b} construct isn't portable: this needs to be runnable with a plain Bourne shell like /bin/dash. I think we should use the same wordlist technique as check_p_numbers[0-6]. So I guess the first step would be to rename check_p_numbers[0-6] to something more general and use it both here and in check_p_numbers. Thanks, Richard