> -----Original Message----- > From: Richard Sandiford [mailto:richard.sandif...@arm.com] > Sent: Monday, August 3, 2020 9:55 PM > To: xiezhiheng <xiezhih...@huawei.com> > Cc: Richard Biener <richard.guent...@gmail.com>; gcc-patches@gcc.gnu.org > Subject: Re: [PATCH PR94442] [AArch64] Redundant ldp/stp instructions > emitted at -O3 >
Cut... > > > > Sorry, I should have used it. And I prepare a patch to use FLOAT_MODE_P > > macro and add a flag FLAG_SUPPRESS_FP_EXCEPTIONS to suppress > > FLAG_RAISE_FP_EXCEPTIONS for certain intrinsics in future. > > The same thing is true for reading FPCR as well, so I think the flag > should suppress the FLOAT_MODE_P check, instead of fixing up the flags > afterwards. > > I'm struggling to think of a good name though. How about adding > FLAG_AUTO_FP and making the FLOAT_MODE_P check dependent on > FLAG_AUTO_FP > being set? > > We could leave FLAG_AUTO_FP out of FLAG_ALL, since FLAG_ALL already > includes FLAG_FP. Including it in FLAG_ALL wouldn't do no any harm > though. I could not think of a better name either. So I choose to use FLAG_AUTO_FP to control the check of FLOAT_MODE_P finally. Bootstrapped and tested on aarch64 Linux platform. Thanks, XieZhiheng diff --git a/gcc/ChangeLog b/gcc/ChangeLog index b834a2c473a..f4a44704926 100644 --- a/gcc/ChangeLog +++ b/gcc/ChangeLog @@ -1,3 +1,9 @@ +2020-08-04 Zhiheng Xie <xiezhih...@huawei.com> + + * config/aarch64/aarch64-builtins.c (aarch64_call_properties): + Use FLOAT_MODE_P macro instead of enumerating all floating-point + modes and add global flag FLAG_AUTO_FP. +
pr94442-v2.patch
Description: pr94442-v2.patch