On Fri, 2020-07-24 at 18:05 -0400, David Malcolm via Gcc-patches wrote:

[...]

> I haven't thought this through in detail, and I'm not sure exactly
> how
> it would work for arbitrary types, but I thought it worth sharing. 
> (For example I can think of nasty issues if we ever want to support
> cross-compilation, e.g. where sizeof types or  endianness differs
> between host and target).

...which is an argument in favor of retaining the name "blob", perhaps
as the name of the argument in the header file e.g.:

extern void
gcc_jit_global_set_initializer (gcc_jit_lvalue *global,
                                 const void *blob,
                                 size_t num_bytes);
 

as a subtle hint to the user that they need to be wary about binary
layouts ("here be dragons").

[...]

Reply via email to