"Kewen.Lin" <li...@linux.ibm.com> writes: > @@ -9195,12 +9222,13 @@ optimize_mask_stores (class loop *loop) > } > > /* Decide whether it is possible to use a zero-based induction variable > - when vectorizing LOOP_VINFO with a fully-masked loop. If it is, > - return the value that the induction variable must be able to hold > - in order to ensure that the loop ends with an all-false mask. > - Return -1 otherwise. */ > + when vectorizing LOOP_VINFO with partial vectors. If it is, return > + the value that the induction variable must be able to hold in order > + to ensure that the loop ends with an all-false rgroup control like > + mask. Return -1 otherwise. */
Maybe: “…in order to ensure that the rgroups eventually have no active vector elements”. > static void > -check_load_store_masking (loop_vec_info loop_vinfo, tree vectype, > - vec_load_store_type vls_type, int group_size, > - vect_memory_access_type memory_access_type, > - gather_scatter_info *gs_info, tree scalar_mask) > +check_load_store_for_partial_vectors ( > + loop_vec_info loop_vinfo, tree vectype, vec_load_store_type vls_type, > + int group_size, vect_memory_access_type memory_access_type, > + gather_scatter_info *gs_info, tree scalar_mask) Think it's more usual in GCC to put the "(" on the same line as the arguments in this situation. OK with those changes, thanks. Richard