On 4/28/20 10:04 AM, Jakub Jelinek wrote:
Hi!
On Tue, Apr 28, 2020 at 08:53:31AM -0400, Jason Merrill wrote:
That sounds good.
So like this? Or better name for the new macro?
The calls.h macro is there only after all the backends are converted
to use ABI_IGNORED_FIELD_P.
Not sure if I shouldn't
if (lookup_attribute ("no_unique_address", DECL_ATTRIBUTES (field))
ABI_IGNORED_FIELD_P (field) = 1;
in end_of_class, as there seems to be some ObjC++ partially overlapping
case too and probably we don't want to change ABI for that.
I would think it would make sense to set it here:
else if (might_overlap && is_empty_class (type))
layout_empty_base_or_field (rli, field, empty_base_offsets);
Jason