Hi, I've committed this small patch as obvious (r278390).
It fixes a typo in check_effective_target_arm_vfp_ok_nocache, which used -mpu=vfp instead of -mfpu=vfp. I also changed the name of the sample test from arm_fp_ok to arm_vfp_ok to match the effective target name, and make it easier to analyze logs. Christophe
2019-11-18 Christophe Lyon <christophe.l...@linaro.org> * lib/target-supports.exp (check_effective_target_arm_vfp_ok_nocache): Fix typo in option name. Index: gcc/testsuite/lib/target-supports.exp =================================================================== --- gcc/testsuite/lib/target-supports.exp (revision 278389) +++ gcc/testsuite/lib/target-supports.exp (revision 278390) @@ -3496,8 +3496,8 @@ global et_arm_vfp_flags set et_arm_vfp_flags "" if { [check_effective_target_arm32] } { - foreach flags {"-mfpu=vfp" "-mfpu=vfp -mfloat-abi=softfp" "-mpu=vfp -mfloat-abi=hard"} { - if { [check_no_compiler_messages_nocache arm_fp_ok object { + foreach flags {"-mfpu=vfp" "-mfpu=vfp -mfloat-abi=softfp" "-mfpu=vfp -mfloat-abi=hard"} { + if { [check_no_compiler_messages_nocache arm_vfp_ok object { #ifndef __ARM_FP #error __ARM_FP not defined #endif