On Wed, Nov 07, 2018 at 05:05:13PM -0500, Fritz Reese wrote: --- a/gcc/fortran/options.c +++ b/gcc/fortran/options.c @@ -32,6 +32,20 @@ along with GCC; see the file COPYING3. If not see gfc_option_t gfc_option; +#define _expand(m) m
I think it would be better to avoid names like _expand, too generic name and starts with underscore, name it e.g. SET_BITFLAG_1 or something similar. And it isn't mentioned in the ChangeLog. @@ -62,14 +75,30 @@ set_dec_flags (int value) } What about the /* Allow legacy code without warnings. */ gfc_option.allow_std |= GFC_STD_F95_OBS | GFC_STD_F95_DEL | GFC_STD_GNU | GFC_STD_LEGACY; gfc_option.warn_std &= ~(GFC_STD_LEGACY | GFC_STD_F95_DEL); that is done for value, shouldn't set_dec_flags remove those flags again? Maybe not the allow_std ones, because those are set already by default, perhaps just the warn_std flags? /* Set other DEC compatibility extensions. */ - flag_dollar_ok |= value; - flag_cray_pointer |= value; - flag_dec_structure |= value; - flag_dec_intrinsic_ints |= value; - flag_dec_static |= value; - flag_dec_math |= value; + SET_BITFLAG (flag_dollar_ok, value, value); + SET_BITFLAG (flag_cray_pointer, value, value); + SET_BITFLAG (flag_dec_structure, value, value); + SET_BITFLAG (flag_dec_intrinsic_ints, value, value); + SET_BITFLAG (flag_dec_static, value, value); + SET_BITFLAG (flag_dec_math, value, value); } --- /dev/null +++ b/gcc/testsuite/gfortran.dg/array_temporaries_5.f90 @@ -0,0 +1,20 @@ +! { dg-do run } +! { dg-options "-fcheck-array-temporaries -fno-check-array-temporaries" } +! +! PR fortran/87919 +! +! Ensure -fno-check-array-temporaries disables array temporary checking. +! Copied from array_temporaries_2.f90. For tests where you expect no errors and that are just copies of other testcases, perhaps include 'array_temporaries_2.f90' or similar instead? Jakub