There was a small typo in the current version of trunk, more precisely in genmatch.c and exp_unst.ads. This patch fixes it.
Changelog: 2018-08-23 Giuliano Belinassi <giuliano.belina...@usp.br> * genmatch.c: Fix typo 'exapnded' to 'expanded'. * exp_unst.ads: Likewise. I don't think this requires a test case :P
Index: gcc/ada/exp_unst.ads =================================================================== --- gcc/ada/exp_unst.ads (revisão 263813) +++ gcc/ada/exp_unst.ads (cópia de trabalho) @@ -477,7 +477,7 @@ -- subprograms exist. Similarly overloading would cause a naming issue. -- In fact, the expanded code includes qualified names which eliminate this - -- problem. We omitted the qualification from the exapnded examples above + -- problem. We omitted the qualification from the expanded examples above -- for simplicity. But to see this in action, consider this example: -- function Mnames return Boolean is Index: gcc/genmatch.c =================================================================== --- gcc/genmatch.c (revisão 263813) +++ gcc/genmatch.c (cópia de trabalho) @@ -4150,7 +4150,7 @@ if (active_fors.length() == 0) record_operlist (id_tok->src_loc, p); else - fatal_at (id_tok, "operator-list %s cannot be exapnded inside 'for'", id); + fatal_at (id_tok, "operator-list %s cannot be expanded inside 'for'", id); } return op; }