On Tue, Dec 19, 2017 at 11:19:44AM -0700, Martin Sebor wrote: > On 12/19/2017 10:58 AM, Jakub Jelinek wrote: > > On Tue, Dec 19, 2017 at 10:49:07AM -0700, Martin Sebor wrote: > > > Can the math be moved into inform_n (and warning_n) itself? > > > > No. I'm against having dozens of inform_n and warning_n etc. > > The question/suggestion is to change the existing inform_n and > warning_n functions to do the math instead of having each caller > do it. (I.e., not add any more overloads.)
The "math" is a mapping from some type (in this case UHWI) to some other type (int, used by our *_n APIs), so that it gives the same plural forms for known translations. Are you suggesting we change the type of the *_n APIs to UHWI instead? What if the caller needs something different? E.g. wide_int, widest_int, offset_int, __int128, whatever else? Jakub