On Fri, Oct 27, 2017 at 11:51 AM, Will Schmidt <will_schm...@vnet.ibm.com> wrote: > Hi, > V3. :-) > > [PATCH, rs6000] (v2) Gimple folding for vec_madd() > > Add support for gimple folding of the vec_madd() (vector multiply-add) > intrinsics. > Renamed the define_insn of altivec_vmladduhm to fmav8hi4, Refreshed the > caller of gen_altivec_vmladduhm to call gen_fmav8hi, and updated the > rs6000-builtin.def entry for VMLADDUHM to point to the new name. > With this refresh I am no longer adding a define_expand. > Plus a few cosmetic tweaks per feedback. > > Testcase coverage is provided by the existing tests as > gcc.target/powerpc/fold-vec-madd-*.c > > Sniff-tests passed. Regtests will be kicked off shortly. OK for trunk? > > Thanks, > -Will > > [gcc]
Thanks for spinning the patch again without the define_expand. The altivec.md ChangeLog entry should be more explicit for each change. > > 2017-10-27 Will Schmidt <will_schm...@vnet.ibm.com> > > * config/rs6000/rs6000.c (rs6000_gimple_fold_builtin): Add support for > gimple folding of vec_madd() intrinsics. > * config/rs6000/altivec.md: Rename altivec_vmladduhm to fmav8hi4 * config/rs6000/altivec.md (mulv8hi3): Rename altivec_vmladduhm to fmav8hi4. (altivec_vmladduhm): Rename to fmav8hi4. > * config/rs6000/rs6000-builtin.def: Rename vmladduhm to fmav8hi4 Thanks, David