On Tue, Aug 22, 2017 at 10:22:37AM +0100, Richard Sandiford wrote: > The comparison results provided by the V_cmp_result/v_cmp_result > attribute were simply the corresponding integer vector. We'd also > like to have easy access to the integer vector for SVE, but using > "cmp_result" would be confusing because SVE comparisons return > predicates instead of vectors. This patch therefore renames the > attributes to the more general V_INT_EQUIV/v_int_equiv instead. > > As to the capitalisation: there are already many iterators that use > all lowercase vs. all uppercase names to distinguish all lowercase > vs. all uppercase expansions (e.g. fcvt_target and FCVT_TARGET). > It's also the convention used for the built-in mode/MODE/code/CODE/etc. > attributes. IMO those names are easier to read at a glance, rather than > relying on a single letter's difference. > > Tested on aarch64-linux-gnu. OK to install?
OK. This name far outlived its descriptive use (as the output type for FCGE etc.), and this sort of rename is the right thing to do. Thanks, James > > Richard > > > 2017-08-22 Richard Sandiford <richard.sandif...@linaro.org> > Alan Hayward <alan.hayw...@arm.com> > David Sherwood <david.sherw...@arm.com> > > gcc/ > * config/aarch64/iterators.md (V_cmp_result): Rename to... > (V_INT_EQUIV): ...this. > (v_cmp_result): Rename to... > (v_int_equiv): ...this. > * config/aarch64/aarch64.md (xorsign<mode>3): Update accordingly. > * config/aarch64/aarch64-simd.md (xorsign<mode>3): Likewise. > (copysign<mode>3): Likewise. > (aarch64_simd_bsl<mode>_internal): Likewise. > (aarch64_simd_bsl<mode>): Likewise. > (vec_cmp<mode><mode>): Likewise. > (vcond<mode><mode>): Likewise. > (vcond<v_cmp_mixed><mode>): Likewise. > (vcondu<mode><v_cmp_mixed>): Likewise. > (aarch64_cm<optab><mode>): Likewise. > (aarch64_cmtst<mode>): Likewise. > (aarch64_fac<optab><mode>): Likewise. > (vec_perm_const<mode>): Likewise. > (vcond_mask_<mode><v_cmp_result>): Rename to... > (vcond_mask_<mode><v_int_equiv>): ...this. > (vec_cmp<mode><v_cmp_result>): Rename to... > (vec_cmp<mode><v_int_equiv>): ...this.