> On Aug 13, 2017, at 3:41 PM, Martin Sebor <mse...@gmail.com> wrote: > >> --- gcc/config/rs6000/rs6000-c.c (revision 250965) >> +++ gcc/config/rs6000/rs6000-c.c (working copy) >> @@ -5812,7 +5812,7 @@ altivec_resolve_overloaded_builtin (location_t loc >> types. */ >> if (nargs != 2) >> { >> - error ("vec_mul only accepts 2 arguments"); >> + error ("builtin %qs only accepts 2 arguments", "vec_mul"); > > I don' meant to nit-pick too much but it has been drilled into me > that the term is built-in, not builtin. There are a number of > deviations from this preferred spelling in GCC messages already > (mainly though not exclusively in the rs600 back-end) but I think > it would be nice to converge on the preferred spelling.
Martin, while I agree with you in principle, for now I have used up the time I have available for messing with diagnostics, so I'm going to go ahead with what we have for now. Spelling patches are of course welcome. :-) Bill > > https://gcc.gnu.org/codingconventions.html#Spelling > > Martin >