On Thu, Sep 22, 2016 at 10:37:21PM +0200, Uros Bizjak wrote: > diff --git a/gcc/hooks.c b/gcc/hooks.c > index > 99ec4014adb6fcbb073bf538dd00fe8695ee6cb2..1e925645c3173f8d97e104b9b2f480fca2ede438 > 100644 > --- a/gcc/hooks.c > +++ b/gcc/hooks.c > @@ -481,3 +481,13 @@ void > hook_void_gcc_optionsp (struct gcc_options *opts ATTRIBUTE_UNUSED) > { > } > + > +/* Generic hook that takes an unsigned int, an unsigned int pointer and > + returns false. */ > + > +bool > +hook_uint_uintp_false (unsigned int, unsigned int *) > +{ > + return false; > +} > > > The name of this hook doesn't adhere to the convention. It should be named: > > hook_bool_uint_uintp_false
You're right, I've committed this as obvious: 2016-09-23 Uros Bizjak <ubiz...@gmail.com> Jakub Jelinek <ja...@redhat.com> * hooks.h (hook_uint_uintp_false): Rename to... (hook_bool_uint_uintp_false): ... this. * hooks.c (hook_uint_uintp_false): Rename to... (hook_bool_uint_uintp_false): ... this. * target.def (elf_flags_numeric): Use hook_bool_uint_uintp_false instead of hook_uint_uintp_false. --- gcc/hooks.h.jj 2016-09-23 09:32:13.000000000 +0200 +++ gcc/hooks.h 2016-09-23 11:57:28.116738504 +0200 @@ -76,7 +76,7 @@ extern void hook_void_tree (tree); extern void hook_void_tree_treeptr (tree, tree *); extern void hook_void_int_int (int, int); extern void hook_void_gcc_optionsp (struct gcc_options *); -extern bool hook_uint_uintp_false (unsigned int, unsigned int *); +extern bool hook_bool_uint_uintp_false (unsigned int, unsigned int *); extern int hook_int_uint_mode_1 (unsigned int, machine_mode); extern int hook_int_const_tree_0 (const_tree); --- gcc/hooks.c.jj 2016-09-23 09:32:13.000000000 +0200 +++ gcc/hooks.c 2016-09-23 11:57:39.938588268 +0200 @@ -486,8 +486,7 @@ hook_void_gcc_optionsp (struct gcc_optio returns false. */ bool -hook_uint_uintp_false (unsigned int, unsigned int *) +hook_bool_uint_uintp_false (unsigned int, unsigned int *) { return false; } - --- gcc/target.def.jj 2016-09-23 09:32:13.000000000 +0200 +++ gcc/target.def 2016-09-23 11:59:03.581525303 +0200 @@ -446,7 +446,7 @@ instead of the normal sequence of letter defined, or if it returns false, then @var{num} will be ignored and the\n\ traditional letter sequence will be emitted.", bool, (unsigned int flags, unsigned int *num), - hook_uint_uintp_false) + hook_bool_uint_uintp_false) /* Return preferred text (sub)section for function DECL. Main purpose of this function is to separate cold, normal and hot Jakub