Hi, On Sat, Apr 16, 2016 at 03:38:57PM +0800, Chung-Lin Tang wrote: > Hi Martin, the attached patch reverts that queue_callback() change, and adds > some more descriptions in the comments to reflect the bool return changes. > Please see if they are acceptable. >
If the rest of the patch-set is approved, this can go in as well. Thanks, Martin > Thanks, > Chung-Lin > > * plugin/plugin-hsa.c (hsa_warn): Adjust 'hsa_error' local variable > to 'hsa_error_msg', for clarity. > (hsa_fatal): Likewise. > (hsa_error): New function. > (init_hsa_context): Change return type to bool, adjust to return > false on error. > (GOMP_OFFLOAD_get_num_devices): Adjust to handle init_hsa_context > return value. > (GOMP_OFFLOAD_init_device): Change return type to bool, adjust to > return false on error. > (get_agent_info): Adjust to return NULL on error. > (destroy_hsa_program): Change return type to bool, adjust to > return false on error. > (GOMP_OFFLOAD_load_image): Adjust to return -1 on error. > (destroy_module): Change return type to bool, adjust to > return false on error. > (GOMP_OFFLOAD_unload_image): Likewise. > (GOMP_OFFLOAD_fini_device): Likewise. > (GOMP_OFFLOAD_alloc): Change to return NULL when called. > (GOMP_OFFLOAD_free): Change to return false when called. > (GOMP_OFFLOAD_dev2host): Likewise. > (GOMP_OFFLOAD_host2dev): Likewise. > (GOMP_OFFLOAD_dev2dev): Likewise. > >